PHP IIS7 Web Platform Installer 3.0 Unsupported OS Error!

OK, so while trying to install PHP 5.3 on IIS7.5 from this page I kept getting an error message saying that I was not using a supported operating system. The issue is that I was using Windows 7 (and later Windows Server 2008) which are both supported operating systems. I don’t have a screenshot of the error, but if you’re reading this – you probably know what I mean. This can’t be an isolated issue and maybe reveals a deeper issue with Microsoft’s bad OS detection mechanism.

How did I fix it? Pretty simple actually. It turns out that I had Web Platform Installer 2.0 installed. The PHP IIS site uses WPI 3.0, so maybe there is a version incompatibility. To get around it I went to Internet Information Services (IIS) Manager, and double clicked “Web Platform Installer” under Management. This did a quick upgrade to 3.0, and then I was able to download PHP 5.3.5 in a snap from the Window that comes up!

Basically – don’t use the website to install it.

Note: Another useful product to install with WPI is “Microsoft SQL Driver v2.0 for PHP v5.3 in IIS” found under “Products”>”Database”. This allows you to easily connect PHP to a SQL Server database using PDO.

God almighty that was a lot of acronyms. I count 6.

Chow,
-Mike

  • DieJex

    Thanks! This helped out a lot!